Archive

Posts Tagged ‘Windows 7’

Back to Linpus on my Acer Aspire One

January 5, 2010 Leave a comment

Well… Windows 7 has had its day, as I move back to Linpus on my AAO.

Why? Well… I wanted to try the next-gen, multimedia, touchscreen, all-singing all-dancing experience on my netbook… but if I’m honest, I don’t really need it. With Win7 installed, there’s precious little space for extra apps… which would be Windows bloatware, usually at additional cost, and with all my media stored on the SSD.

I just want to browse the Web, review/upload photos, maybe with a bit of editing, and do it quickly and simply, without worrying about page files, battery life, write-optimisation, etc. And I had that already with Linpus, along with all the Open Source stuff like GIMP, and I could practice my Linux too.

I might try Ubuntu netbook edition at some point. But I only use the damn thing about once every three months (I have a Dell monster for work), so I’ll take my time.

Advertisements

Got there! Gigabyte GA-G33M-S2H now running Windows 7 64-bit

November 1, 2009 Leave a comment

Perhaps the last 3-4 posts I’ve made have reflected the countless hours I’ve spent trying to get 64-bit Windows 7 installed on my Gigabyte motherboard. Now, finally, I’ve managed it.

Win7

In the end, I cheated. What I did was simply:

  • Install an old 64-bit Windows to a new partition (I chose Windows Server 2003 R2 64-bit)
  • Run that 64-bit Windows, and then run the Windows 7 64-bit installer from within Windows  – and install to another partition

The reason for this alternate route, was because my Gigabyte board repeatedly refused to boot from the 64-bit installer media directly. My best guess for the reason, from a lot of experimentation, is that the board disagrees with the bootloader on the newer operating systems (Vista, Windows 7, even Ubuntu), but would still work with the older bootloaders.

Along the way, I found:

  • You can run the installer from within an older version of Windows (mine being XP), but you can only go from 32-bit to 32-bit, or 64 to 64. Since I currently run 32-bit, and wanted 64, this wasn’t a quick option.
  • You CAN boot from USB Flash Drives on Gigabyte motherboards like mine, but you have to plug it in, go to the BIOS, and treat it like an internal HDD – moving it ahead of the others in the HDD Boot Order in Advanced Settings. Selecting USB-HDD, for example, seems ineffective. However, once I got this working, Win7 started to boot, but still failed before it got anywhere useful.*
  • Unplugging and disabling every single peripheral, including AHCI, Virtualisation, Serial/Parallel, USB devices, TV card, PCI cards, RAM, Optical Drive, even all the HDDs!, had no effect on the boot failure
  • You can’t try to run the setup in VMWare instead to do an install to physical disc, since VMWare Server 1.x doesn’t support Windows 7, and 2.x doesn’t support writing to physical discs.**

So, now this is working, I’ll immediately take a clean image using BootIt NG, and then start the long process of building up all my apps to get the same operability as I had in XP.

Notes:
* – Although my initial install from within Server2003 also  failed from the USB stick – and then succeeded from ISO image – so maybe the files did actually corrupt that time round. So this approach might still work…
** – There is a hack to write to Raw disc in Linux. But whether you have the patience to find a Linux distro that will install, then install VMware inside that, then create a VM, and try to install Win7 in it… and then hope it’ll boot successfully direct from that installation despite all the different devices…… is another question.

Still no joy with Win7 64-bit

October 31, 2009 Leave a comment

OK – just tried a couple more tricks to install Win7 64-bit

First – I tried building a bootable HDD using VMWare, and then boot from that in the GA-G33M-S2H BIOS. Nonstarter. VMWare Server 2.0 can support a guest Win7 OS, using the Win Server 2008 profile, but doesn’t support Physical Discs (and there’s no point building a virtual disc, as I can’t boot from that!). There’s a hack for that for Linux, but not Windows.

VMWare Server 1.x DOES support physical discs… but doesn’t support Windows 7. It stops on booting with a bluescreen error.

I also tried attaching my optical drive as a USB – by using an IDE-USB2.0 cable which I picked up on eBay. Handy, as I don’t even have to remove the drive from the case. However, it experiences exactly the same problems as when using the drive directly connected.

PXE Boot could be possible… but is tricky to set up. It is annoying that the GA-G33M-S2H doesn’t support bootable USB sticks, as this is how I built my netbook.

OK – next attempt is to boot my laptop to Win7, and build an install onto a removable HDD, then try to boot from that on the PC. I suspect it won’t work, since the wrong drivers will be installed… but all I need to do is get to an OS, and then run the installer fresh.

Windows 7 on Gigabyte GA-G33M-S2H – not there yet

October 29, 2009 3 comments

OK, so I got Win7 up and running on my Gigabyte board, by installing from within WinXP. It seems the issue is the same boot issue as I had with Ubuntu and XP before this, rather than Win7 specifically.

So – I’m there, right?

Well – not really. Because that test install was using Win7-x86 (32-bit). And when I tried the same trick with 64-bit… you’ve guessed it… the setup program wouldn’t run from within WinXP, as it’s 32-bit.

So… now I need to figure out a way to install the 64-bit version… since I still can’t boot from CD or USB…..

Two possible methods:
1. Network PXI boot?
2. Install it inside a 64-bit VM, but to the physical partition… then boot natively from that partition. (Messy with the drivers!)
3. Run the initial installer (ie. copy over files, setup boot) using the VM – but then run the rest of the install natively, after the first reboot.

Whatever I do, it’s going to be messy…

Finally installed Windows 7 on GA-G33M-S2H

October 29, 2009 Leave a comment

By chance, I found a solution.

I had just burned a stored ISO on Win7 32-bit to try an install with, and accidentally put the DVD back in, which then autoplayed.

It offered me the chance to install Win7 from within XP. I try to avoid this normally – I prefer to boot straight into the install – but this time I let it run.

It accepted my pointing to an empty partition, installed, and rebooted… And started up within Win7 successfully! It completed the installation, and rebooted a couple of times more. It retained my original XP partition, and correctly handled the boot loader to choose between the two.

So – it seems it’s the same problems that mysteriously stopped me installing Ubuntu or WinXP when I first bought the motherboard. I didn’t work it out then, and I haven’t now, but if it works, that’s good for me!

Now to try 64-bit…

Hoda / eGalax EETI Touchscreen now working in Tablet Mode with Windows 7

September 22, 2009 14 comments

Well, after going through my previous post, it turns out that the technique to get Tablet mode working DOES work, pretty much as the forum posting describes.

In short:

  1. Download the Tablet drivers for the touchscreen from this link.
  2. Uninstall your existing touchscreen driver software (ie. TouchKit), and go to Device Manager to ensure that the HID USB Device is removed from the Mouse list.
  3. Reboot, if required.
  4. If Windows tries to autodetect and re-install the HID USB Drivers, then uninstall them again by right-clicking the entry in Device Manager
  5. Run Setup.exe from the Tablet drivers that you downloaded, and follow the install instructions straight through.

And that’s it – the Tablet-related control panel options are now accessible, and a circular crosshair appears whereever you touch.

Now the bad news.

It’s not really worth the bother. For anyone who’s used an iPod Touch or iPhone, the Windows Touch gestures are laughable. Swiping your finger down on a web page, if you manage not to simply select text, basically sends a Page Down keypress to the browser – so it simply scrolls down a page, regardless of how you swiped. Compared to OSX, where the scrolling has momentum and speed, it’s a very poor substitute.

As for Media Centre; does it have swipes? Can you flip through albums. Well… No! Instead, tablet mode gives you touch buttons at the top and bottom to scroll through the options. Again, laughably backward for a not-yet-released OS.